miércoles, 12 de febrero de 2014

Advertencias con el módulo warnings

Si la versión de un programa está por debajo de la 3 genera un “warning” personalizado.

import sys, warnings

if sys.version_info.major < 3:
    warnings.warn('Necesitas Python 3.0', RuntimeWarning)
else:
    print('Tiene la versión de Python adecuada')

No hay comentarios: